Elevated disconnects on api.url2png.com
Incident Report for url2png
Resolved
Service restored
Posted over 4 years ago. Mar 20, 2015 - 12:33 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted over 4 years ago. Mar 20, 2015 - 12:26 EDT