elevated rate of 500s in production
Incident Report for URL2PNG
Resolved
Making as resolved at this time. We will post an additional update once public statements are available from AWS on their ongoing DNS challenges today.
- https://news.ycombinator.com/item?id=21327980
Posted Oct 22, 2019 - 18:38 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 22, 2019 - 15:53 EDT
Update
The upstream dns/network issue has gotten considerably worse. At this time we have deployed a fleet wide work around. Error rates should continue to drop with this in place. We are actively monitoring the situation and will update as we deploy any additional resolutions.
Posted Oct 22, 2019 - 15:45 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 22, 2019 - 15:40 EDT
Update
Posted Oct 22, 2019 - 12:28 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 22, 2019 - 08:40 EDT
Investigating
Some request types are experiencing an elevated rate of 500s. Initial evidence points to transient upstream connectivity issues, but we are investigating as current status updates from AWS/DigitalOcean do not account for our regions at this time.
Posted Oct 22, 2019 - 08:21 EDT
This incident affected: API - Legacy.