aggressive rate limiting is impacting some customers

Incident Report for URL2PNG

Resolved

This incident is marked as resolved. We will continue monitoring for unexpected rate limiting events over the next days. If you feel your traffic is being impacted, please pro-actively reach out to support.
Posted Jan 17, 2026 - 15:21 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 17, 2026 - 09:00 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 17, 2026 - 07:36 EST
This incident affected: API - Capture.